MODELLING FUNDAMENTALS - Simple House

Setting up a New Model

The first step is to ensure you are working on a new blank document, and that the working grid is set appropriately.

  1. Select the New item from the File menu, (or click the New button).

    This clears the model memory and reloads the default material data.
  2. Select the Perspective item from the View menu (or hit the F8 key).

    This ensures you are looking at a 3D perspective view of the grid. If your view isn't similar to that shown in the above diagram, simply click the Right Mouse button in the Drawing Canvas and drag the view around until it fits. Use the Shift and Control keys, in combination with holding down the Right Mouse button, to zoom and pan the view respectively.
  3. Select the Fit Grid to Model item in the View menu (or use the Fit Grid button).

    If there are no objects in the model then this sets the grid to the default grid settings. Otherwise it fits the grid to the extent of the objects in the model.
  4. To check the grid settings select the Grid Settings item in the view menu (or use the Model Settings button on the Main toolbar, and select Grid tab).

    This invokes the Model Settings dialog box, allowing you to manually specify grid dimensions. In this case we are only going to check the values, making sure they correspond roughly to the ones below.

  5. Select User Preferences from the File menu, then select the Cursor Snap tab (or simply press the Snaps button on the Options toolbar and select Settings).

    This is to ensure that snaps are set appropriately. It is recommended that the snaps shown below are used. By using the Snaps button on the Options toolbar (or their corresponding keyboard shortcuts) it is possible to change snap settings at any time, even in the middle of creating or modifying objects.



    It is also possible to determine current snap settings and change them, by using the Snaps Status panel at the bottom left of the program window. Letters in black refer to snaps that are on, whilst those in white are off. To change the snaps using this panel, simply click the letters once, with the Left Mouse button.

Adding the First Zone

The next step is to create a new zone for the first part of the building. This is going to be a simple rectangular box.

  1. Select the Zone item from the Draw menu (or use the Zone button).

    This will begin the creation of a new zone object, with walls, and a ceiling, extruded from a single floor object.
  2. Move the cursor over the Drawing Canvas.

    This displays the Node Input cursor with the red X and Y axis. As you move the cursor around the Drawing Canvas the Cursor Input toolbar updates, with the absolute X, Y and Z location for the first node.

  3. Type 1000 in the X and 1000 in the Y input boxes and hit the Enter key.



    This starts the zone, with the first node at the absolute coordinates 1000, 1000, 0.
  4. Move the cursor around the Drawing Canvas.



    If you move the cursor around the Drawing Canvas now, you will notice that the Cursor Input toolbar updates with X, Y and Z values relative to the last node that was entered. As well, if the cursor is moved in the X direction, the X Cursor Input box has the focus. If moved more in the Y direction, the Y Cursor Input box will get the focus.

    You should also notice that the X and Y axis are snapped to and highlighted, (if Orthographic snaps are set as previously stated). This makes it quick and easy to generate orthogonal objects.

    Finally, you may see a distance value displayed in the centre of the line segment currently being entered (if the ECOTECT defaults are set). This is to assist in drawing accuracy, but if not preferred can be turned off from the Modelling tab in the User Preferences dialog box by un-checking the Display Interactive Distances option.
  5. Move the cursor some distance in the X direction, type 13000 and hit the Enter key.



    This creates the first wall segment of the zone, using the default extrusion height. The default extrusion height can also be changed from the User Preferences dialog box, or the height of any zone can be changed after it is created (this will be explained later in this tutorial).
  6. Move the cursor some distance in the Y direction, type 5000 and hit the Enter key.



    This creates the second wall segment of the zone.
  7. Move the cursor in the -X direction, type 13000 again.



    This creates the third wall segment of the zone.

    Note that you do not have to enter a minus sign in front of the 13000 to get it to move in the negative X direction, it simply moves 13000 in the direction of the mouse.
  8. Hit the Esc key on the keyboard (or right click in the Drawing Canvas to display the Context menu, and select Escape).



    This finishes the creation of the first zone and displays the Rename Zone dialog box.

    At this point it is necessary to type in an appropriate name for the zone. This then adds a new zone to the list of zones in the model. When a zone is created using the button or menu item, this dialog box will always appear.

Adjusting the Zone Height

The next step is to alter the height of the zone, which was automatically extruded to a default height of 2400mm (specified in the User Preferences dialog box). This extrusion height can be changed at any time for any object that maintains its linking.

  1. Using the Select button (which it should already be set to), select the floor element of the zone.

    If you are having trouble selecting the correct element, use the Spacebar key on the keyboard to cycle through adjacent objects or simply keep the Left Mouse button down when you select and then drag slowly in any direction to cycle through adjacent objects.

    Selected objects may show up as either yellow in colour (as in the image below), or with a thickened line. This setting can be changed from the User Preferences dialog box, either by choosing a Selection Highlight type from the selection box, or by altering the Selection Colour.



    The floor element of any zone created using the Zone button or menu item, is the parent of all other objects extruded from it. This means that the floor controls the other objects, making it easier to edit the entire zone after it has been created.
  2. With only the floor element selected, change the Z value in the Extrusion Vector input boxes in the Selection Information panel, to the right of the Drawing Canvas.

    This can be done either by typing in the number, or by dragging the small arrows that appear after clicking in the input box (as shown n the image below).



    This value alters the entire zone's extrusion height.

    In any of ECOTECT'S input boxes you can also enter any type of equation or dimension as long as it is annotated correctly. (For more information on entering data, go to Entering Data in the User Interface section of ECOTECT'S main help file.

    As an example, try entering 2000+1000 then hit the Enter key. This will change the value to 3000 in the input box.
  3. To apply this change to the selected object, you will need to click the Apply Changes button at the bottom of the Selection Information panel.



    To automatically apply changes made, therefore not requiring you to click the Apply Changes button after altering values, simply check the Automatically Apply Changes check box at the bottom of the panel. This can also be done for the Material Assignments panel.

    If the Automatically Apply Changes check box is already ticked, you need only hit the Enter key after making an alteration for it to take effect.
  4. To permanently change the height of subsequent zones, select User Preferences from the File menu, then select the Modelling tab (or simply press the button on the Main toolbar and select Modelling).



    In the Default Zone Height input box enter 3000 as the new value. This ensures that every zone created from now on will be 3 meters high. Click the OK button when you've finished entering the new value.

Adding a Second Zone

The next step is to create the zone on the north side. For this, we want one of the nodes to be in the exact centre of the north wall. This time we are going to work more within the Drawing Canvas, and use object snapping to ensure the model is accurate.

  1. Select the Zone item from the Draw menu (or use the Zone button).

    This will begin the creation of a new zone object.
  2. Move the cursor over the Drawing Canvas until you snap to the Mid Point of the north side of Zone 1.



    You can tell which side is on the North by the arrow in the far left corner of the grid.

    Snaps are displayed with a small letter corresponding to the appropriate snap type. Move the mouse until a small M appears at the cursor, and click with the Left Mouse button to accept the point.

    If a small M does not appear it is most likely that Mid Point snaps have not been set. To do this (whilst still in command) click the Snaps button on the Options toolbar and make sure that Mid Points has a tick next to it, or hit the M key on the keyboard.
  3. Move the cursor in the X direction and type 5000 (do not hit the Enter key).



    After typing 5000 move the cursor around the Drawing Canvas. Notice how the cursor is constrained by 5000 units in either positive or negative X. Notice also that the cursor will snap to the X axis as you move close to it, this is because Orthogonal snaps are also on.
  4. Move the cursor so that it snaps to the X axis with the set value of 5000, and click the Left Mouse button.



    Once the desired point has been chosen with the mouse, simply clicking the Left Mouse button will accept that position and move on to the next node placement.
  5. Move the cursor in the Y direction, type 4000 and click the Left Mouse button.



    This creates the second wall segment of the zone.
  6. Using the Snaps pull-down menu from the Options toolbar, set the Align snap to on.

    This time we are going to use the Align snap to finish the last two wall segments of our new zone.



    With Align snaps on, move the cursor back along the X axis until a small XY appears next to the cursor. This is telling us that the cursor is aligned with other nodes in both the X and Y axis. If we were only aligned with a node in the X, only a small X would appear (same with the Y and Z axes).
  7. Once the cursor is aligned in the X axis with the last node entered, and in the Y axis with the first node of the zone, click the Left Mouse button in the Drawing Canvas.



    This creates the third wall segment of the zone, and with align snaps on we know it's a perfectly orthogonal zone.
  8. Hit the Esc key on the keyboard (or right click in the Drawing Canvas to display the Context menu, and select Escape).



    This finishes the creation of the second zone and displays the Rename Zone dialog box. Enter an appropriate name for this zone then click the OK button.

Adding Windows and Doors

We are now going to add a couple of windows and doors to the two zones. This can be done using either parametric library objects, or manually using the mouse. We are only going to use the parametric method in this tutorial.

  1. First deselect all objects by clicking an empty area of the Drawing Canvas (or choose the None item from the Select menu).

    This makes sure that we are not trying to add windows to all the selected elements.
  2. Select the northernmost wall of Zone 2 using the Select button.



    Notice as you move the cursor close to an object that the cursor changes. This cursor tells you that a selection can be made. Again if you find it difficult to select the wall, use the Spacebar key on the keyboard to cycle through the nearby objects.
  3. Once the wall is selected hit the Insert key on the keyboard to insert a child object (in this case a window).

  4. With the dialog box open, select the Window button at the top and enter values roughly similar to the ones shown above.

    The default insertion point for any child object is the exact centre of it's parent object. These values are listed to the bottom of the Insert Child Object dialog box, and can be changed by entering different values.

    ECOTECT will not let you position a child object outside the limits of it's parent. Therefore if inconsistent values are entered ECOTECT will move the child object until it fits within its parent.

    Once you've finished entering values click the OK button.

  5. Now that the window is inserted in the middle of the wall, try nudging the window around the wall using the X, Y and Z keys on the keyboard.

    When moving the window around, it will always move in the plane of its parent. You should also notice that it will not let you move the window outside the wall. This is simply an exercise to show that you can interactively move any object, subject to its relationship links. Try to manually reposition the window back to the centre, or as close as you can.

    When using the nudge keys (X, Y, Z) the amount which you nudge by is set by the Cursor Snap/Nudge Value input box on the Options toolbar. The default setting for this is 100mm but it can be set to any value by typing in the input box and hitting the Enter key on the keyboard, or by clicking the up / down arrows to the right of the input box.

    To nudge an object in a negative direction hold the Shift key down whilst pressing either the X, Y or Z key.
  6. Now try inserting a window on the northern facade of Zone 1.

    This time make the window 1500mm high, 3000mm wide and a sill height of 1000mm. If you insert the window in the centre of the wall it will have to be nudged in the negative X direction until it looks similar to the image below.

  7. Now try adding a door between the two zones using the same method we used for adding a window but by selecting the Door item form the child object list.

    Make the door 2100mm high, 900mm wide and position it approximately 1000mm from the western wall of Zone 2.



    When adding either a Window, Door or Void child object in a wall that is adjacent to the wall of another zone, you only have to add the child object in one of the two adjacent walls. ECOTECT when calculating inter-zonal adjacencies works out that the object will pass through to the other zone letting in heat, light, air and sound according to the material and objects properties.

    This is different with a Panel child object, as a Panel denotes a different type of material within a wall and only effects the zone within which it is contained.
  8. Enter the final door in the eastern wall of the second zone.

Creating a Pitched Roof

The next step is to add the roof objects, with a 600mm overhang.

  1. Select the Pitched Roof item from the Draw menu (or use the Roof button).

    The first time this is done, ECOTECT requires you to enter a base-plane with the cursor in the Drawing Canvas (subsequent use allows editing of previous base-plane). It also displays the Parametric Objects panel to the right of the Drawing Canvas.

    At this stage you can either enter values in the panel, or draw / adjust the base-plane interactively. In this instance we are going to draw in the base-plane interactively.
  2. To draw your first base-plane, left click the mouse on one top corner of the first zone, then on the opposite corner.

  3. You should end up with a base-plane that looks like the one in the image below.



    Once the node is snapped to the corner (a small P should be displayed next to the cursor, if not check that Point snaps are on in the Snaps button on the Options toolbar) click the Left Mouse button to accept the point.
  4. You now need to check the details that appear in the Parametric Objects panel to the right of the Drawing Canvas.




    The most important things to check are that Roof Type is set to Gable, Ridge Axis is set to X-axis, and the Eaves Depth is set to 600mm.
  5. To complete the roof, click the Create New Object button at the bottom of the panel.



    The roof is created with an over hang of 600mm. Now try creating the roof for the second zone, this time changing the Ridge Axis to Y-axis, as the roof needs to run in the opposite direction to the first.



    Now if you take a look at the two roof objects you will notice that they do not join correctly.
  6. To fix this, we need to enter Node Mode so that the nodes of the second roof object can be edited. To do this select the Nodes item from the Select menu (or hit the F3 key on the keyboard).

    Once in Node Mode, we need to view the model from the side. To do this, select the Side item from the View menu (or hit the F6 key on the keyboard).

  7. Once in side view drag a box around the nodes at the bottom left corner of the second roof.

    With the nodes of the bottom left corner selected, use the nudge keys to shift the nodes in the positive Y direction until the edge lines up with the edge of the first roof object.



    The edges should match up using the current snap setting of 100mm, but if not it may need to be changed in the Options toolbar.
  8. With the bottom nodes lined up, select the uppermost nodes on the left side and nudge them in the negative Y axis until they line up with the ridge of the first roof object.

  9. Finally return to perspective view by selecting the Perspective item from the View menu (or hitting the F8 key on the keyboard).



    In perspective view spin the model around to check the changes we just made, and to have a look at the completed house.

    To do this click and hold down the Right Mouse button whilst dragging the mouse around the canvas.
    Also try changing the display to Rough Sketch mode, by selecting Rough Sketch from the Display menu.

Importing DXF Files

  1. From the File menu select the Import item. Then from the Tutorial directory in your ECOTECT Install directory, locate the file Trees.dxf.

    You may need to select AutoCAD DXF from the Files of Type selection box.
  2. This should display the File Conversion dialog box.

    If the settings are similar to those displayed in the image below, click the OK button.

  3. Two trees are displayed as part of the model, and the grid resizes to include the new objects.

    Once the trees have been imported, select them and in the Object (first) section of the Selection Information panel, check that the zone is set to Outside.

    If not, with the objects still selected, click the Zone input box, then click the Options button once it appears, and choose the Select Zone... item from the list.

  4. The Select Zone dialog box should appear containing all the zones in the model. Choose the Outside zone from the list and click OK. The objects will now exist on the Outside zone.

    It is very important that external objects such as the trees and for example shading devices are not left on a thermal zone. If the objects were left on a zone that was to be used for calculating thermal performance, they may alter the results calculated. This is because the additional surface area, from in this case the trees, would add to the solar gains of the zone possibly distorting the loads for that zone.
  5. Finally shift the two trees in the negative X direction by hitting the Shift + X key, until the model looks similar to the one shown below.