MODELLING FUNDAMENTALS - Classroom

Creating a Zone using Interactive Measurements

The first step is to ensure you are working on a new blank document, so that you can start the first zone.

  1. Select the New item from the File menu, (or click the New button).

    This clears the model memory and reloads the default material data.
  2. Starting at 0, 0, 0 with the point marked with an X in the above diagram, try creating the first zone with the dimensions shown above.

    Using the Create Zone tool in the Modelling toolbar, input the first point in absolute coordinates in the Cursor Input toolbar. Then type in the successive nodes using the dimensions given.

    If you are unsure how to do this and have not done the Simple House tutorial, please refer to that. Otherwise, if you have done the first tutorial or if you feel experimental, the Cursor Input toolbar appears in the top toolbar as soon as you enter a modelling command. Simply move the mouse in the direction you want to go and type a value when that axis' text box receives the input focus. This locks that axis, meaning that you can now drag the mouse in another axis and enter a further value. To accept a point, simply click the Left Mouse button in the Drawing Canvas or hit the Enter key. You want to end up with something that looks pretty similar to the following diagram.

  3. Hit the Escape key to finish creating the zone.

    Once you have reached the last node, finish the zone and in the Rename Zone dialog box give it a unique name.

  4. Select and delete the existing Ceiling element so that it can be replaced with a raked ceiling and roof.

    The Spacebar key on the keyboard will help in cycling between adjacent objects.

  5. With the Create Line tool draw a line from the middle of each end of the zone, at roof level.

    You may need to check your snap settings to ensure that you have Mid Point snaps on. You need this line in the exact centre as you are going to use it to construct the new ceiling / roof.



    Once the two points have been entered, hit the Escape key on the keyboard to finish the command.
  6. With the line selected, go into Side view and, using the Move tool (Transform toolbar), shift the line up in the Z direction 1100mm.

    To do this, press the F7 key to enter side view, then click the Move button and move the mouse to snap to one end of the zone at the top. Then click the Left Mouse button to start moving the selected line, then drag the mouse in the Z direction and type 1100 to limit the move to that distance. Finally, click the Left Mouse button again to accept the new position.

  7. Once you have moved the line up, change back to Perspective view by hitting the F8 key. Now you need to add four planes to describe the roof.



    Using the Create Plane button, snap to the existing geometry and create four separate roof elements, two flat and two sloped. Try using the F2 key to repeat the last command.



    When you have finished with the construction line you created earlier, select it and delete it from the scene.
  8. Take a look at the model in Rough Sketch mode (Display menu).

    As you can see there are two triangular holes at either end of the zone which you will need to fill. It is important for thermal and acoustic calculations that all zones are completely enclosed volumes (for more information on this, refer to Layers & Zones in the Concepts section of the ECOTECT Help File).

  9. Select the wall element at the end of the zone, then select the Add Node button.

    By adding a node to the top of the wall you will be able to cover the hole with a five sided wall segment.

  10. Move the cursor to the center of the top wall segment and click the Left Mouse button.

    Now the new node is attached to the cursor and you can move it into the correct position at the ridge line. To finish click again with the Left Mouse button.


    Now do the same to the other end of the zone, so that it looks like the image below.

Adding Windows

You are now going to add several windows to the zone, and this time you are going to use the cursor method. The easiest way to do this is by setting up a series of construction lines.

  1. First create a line that runs at the base of the southernmost wall of the classroom, and move it up in the Z axis 700mm (the easiest way is by using the Z key on the keyboard).

    When using the nudge keys (X, Y, Z) the amount which you nudge by is set by the Cursor Snap/Nudge Value input box on the Options toolbar.

    Then copy and paste this line (Ctrl+C then Ctrl+V), and move the copy up further in the Z axis another 1200mm.



    The lines should look like the ones above. These are going to be the sill and top of the windows.
  2. Now create a vertical line that runs between the far end points of the two previous construction lines, then nudge it 750mm in the positive X direction using the X key (it should look like the image below in side view F7).



    Create a copy of this vertical construction line (Ctrl+C then Ctrl+V), and nudge it a further 2000mm in the positive X direction.
  3. To create a window child object you must first select the object to insert the window into (in this case the southernmost wall).

    Then select the Window button from the Modelling toolbar, and using the construction lines to snap to, draw the window as in the image below.



    Hit the Escape key to finish creating the window.
  4. Before creating duplicate windows, delete the four construction lines.
  5. To create an additional five duplicate windows, select the first window then choose the Duplicate item from the Edit menu.

    In the Duplicate Selection dialog box, enter 2500 in the X offset and make sure the Y and Z offsets are set to 0.



    Make sure the Don't prompt me again check box is ticked, then click the OK button. Continue to hit Ctrl+D on the keyboard until there are a total of six windows in the wall.

Copying (transforming) Child Objects

You now need to create a similar set of six window in the northernmost wall. To do this you will need to unlink the existing six windows from their parent wall, copy the windows to the northern wall, then re-link the windows back to their respective walls.

If you tried to transform (in this case copy) the windows without first unlinking them, it would be impossible to move them outside the plane of the wall. This is because the object linking of a child object ensures that the child is physically constrained within the boundaries of the parent wall.

It is also very important to re-link the windows back to the wall that they are to exist within. If this is not done, the window will exist on top of, not inside the wall. As a result the window would not act like a hole in the wall for light, heat etc. to pass through.

  1. Select the existing six windows and unlink them from the parent wall, either by clicking the Unlink Objects button, or by choosing Unlink Objects item from the Edit menu.

    To select multiple objects hold down the Shift key to add to the selection set, or the Control key to remove objects. A small + or - sign will appear next to the respective selection cursors.
  2. Once unlinked and with the six windows still selected, select the Move button from the Modelling toolbar.

    To make sure that you are copying the objects not just moving them, make sure the Apply to Copy check box in the Options toolbar is ticked. Now with the cursor in the Drawing Canvas, snap to the bottom corner of the southernmost wall and left click the mouse button to start the copy.



    The six window objects are now attached to the cursor.

    To finish the copy, left click again on the corresponding corner of the northernmost wall. Then to cancel the command hit the Escape key (you could continue to copy the objects elsewhere as well but in this instance it is not required).
  3. Now that the windows are copied you need to re-link them.

    To do this select one set of six windows plus the wall within which they need to belong, and choose Link Objects item from the Edit menu or hit Ctrl+K on the keyboard. Then do the same with the other six windows and wall.

    If you have trouble selecting the required objects, as mentioned before the Shift and the Control keys will add / subtract from the selection set, and in combination with the Spacebar key you can cycle through neighbouring objects.
  4. As a final step, you need to check and make sure the windows are linked correctly. There are a couple of ways this can be done.

    One way is by selecting one of the windows, then choosing the Parent item from the Select menu. This should then select the object's parent. If no objects are selected after having done this then the original object doesn't have a parent, and thus is not linked.

    You could also do the a similar test by choosing the wall object, then choosing the Child item from the Select menu.



    Another way to check is by viewing the model in Rough Sketch mode (Display menu). As in the image above, if the windows appear as holes in the wall then they are linked to the wall. If they appear opaque then they are not linked. This method only works when the child object's material definition has a transparency equal or greater to 0.2 (20%).

Inserting Multiple Doors

You know need to add four doors, which will be exactly the same, to four different elements in the seen.

  1. Select the four small east and west facing wall elements using the Select tool, the Shift key to add to the selection and the Spacebar to toggle selected elements.

    Another way to easily select the objects is to drag selection windows around each wall (this is best done in Plan view, F5 key), with the Shift key held down to add to the selection as you go.

    If selecting objects using a selection window, it is important to note that if you drag from left to right the selection will contain all objects that are contained inside the selection window, and if you drag from right to left the selection will contain all objects that cross the selection window. This is shown in the Drawing Canvas by a selection window with either, a solid red or a dashed red line respectively.

  2. With the four walls selected, hit the Insert key on the Keyboard to invoke the Insert Child Object dialog box.

    Select the Door button at the top, then enter a height of 2100mm and a width of 900mm. Leave the insertion point of the door as is (i.e. the centre bottom of each of the four walls).
    Then click the OK button when you've finished entering the data.

Adding a Ridge Skylight

To do this you are going to create a series of construction lines within the roof plane to help draw the skylight, similar to how you created the first window in this tutorial.

A skylight is the same as a window object. The difference lies in the properties of the material assigned to the object.

  1. First draw a line along the ridge of the roof.

  2. Next, using the Move tool, move the line down the roof by a distance of 1000mm.

    The easiest way to do this accurately is to choose the end point of the line as the base point for the move, then switch the cursor input method from Cartesian to Polar by clicking the Cartesian Coordinates button at the of the Cursor Input toolbar (it should now look like this ). Once that's done move the cursor in the Drawing Canvas down the roof line until it snaps to the mid point of the end of the roof plane.

    Now with the cursor still snapped, type in the required distance, 1000. Having typed 1000 the cursor is now restricted in movement by a distance of 1000mm, as can be seen in the Cursor Input toolbar.

    Still with the cursor snapped to the roof's mid point, left click the mouse to accept the final location of the line.



    The reason for changing from Cartesian to Polar coordinates was to allow us to move the line a specified distance but along an unknown angle (the line of the roof). This would not have been possible using Cartesian coordinates, as it only allows distances in the X,Y and Z axis. By using Polar coordinates the relative distance from the base point was easily specified, and the angle was taken from the roof line having snapped to it's geometry.
  3. Now create a copy of this first construction line 500mm further down the roof.

    The easiest method is as described above, but this time making sure that the Apply to Copy check box is ticked.
  4. Finally create two lines that run between the end points of the previous construction lines, and move them towards the centre of the roof a distance of 1000mm.

    Moving the two small line segments is best done by using the X (and Shift X) key on the keyboard to nudge the objects.



    The construction lines should look similar to the image above in plan view.
  5. Once the construction lines are done, you can draw in the skylight.

    Use the Window tool to draw the first skylight, making sure the roof object (the parent) is first selected and you snap to the construction lines.
  6. Delete the construction lines once this is done.

Mirroring Child Objects

To create a copy of the first skylight in the other side of the roof you are going to copy the original one by mirroring it.

  1. First remember to unlink the original skylight from it's parent (roof object) by selecting it and hitting Ctrl+U on the keyboard.

    If you don't unlink the object before mirroring it you wont be able to move it from within it's parent.
  2. Next choose the Mirror tool from the Modelling toolbar (in the Transform pull-right).

    As soon as the Mirror tool has been selected the Origin icon appears in the Drawing Canvas (probably towards the far left corner of the building 0,0,0).



    The Origin is required by the Mirror tool as it defines the point about which the mirror is to occur.
  3. Before actually starting to mirror the skylight, move the Origin to one end of the ridge line of the roof.

    To do this (whilst still in the Mirror command) move the cursor over the top of the Origin until it snaps to it. This is indicated by a O next to the cursor.

    Once snapped to the Origin, click once with the Left Mouse button to start moving it, move the cursor to the ridge of the roof, then click once again with the Left Mouse button to complete the move.

    Finally before starting the mirror, make sure the Apply to Copy check box is ticked.
  4. Now that the Origin is in the correct location (and you'll be making a copy of the original), start the Mirror command by moving the cursor to the other end of the roof's ridge and clicking the Left Mouse button once.

    If you move the cursor around the Drawing Canvas now you should notice that the new mirrored object is attached to the cursor along the axis created between the Origin and the point at which you started the Mirror command (as shown below).

  5. To finish the mirror, click the Left Mouse button once somewhere in-line with the roof's ridge (this can be the same point that you started the Mirror command with).

    Then hit the Escape key on the keyboard to make sure the Mirror command is not still active.
  6. Finally you need to link the two skylights back up with their respective roof objects.

    Select the first skylight and roof object and hit Ctrl+K, then do the same with the second two.

    The completed model should look like the one shown below.