MODELLING FUNDAMENTALS - Auditorium

Using Construction Lines to Setup a Model

The first step is to set up a new drawing with construction lines on a separate zone.

  1. Select the New item from the File menu, (or click the New button).

    This clears the model memory and reloads the default material data.
  2. Select the Zone Management panel to the right of the Drawing Canvas. With the panel visible, create a new zone called Construction Lines by clicking the arrow at the top right corner of the panel and choosing the Create New Zone item.

    Give the new zone a colour other than white, and make sure that it is set as the Current Zone indicated by bolded text (double click a zone name to make it the current zone, click the zone colour swatch to display the colour pallette).

  3. Starting at 0, 0, 0 with the point marked with an X in the diagram below, create the lines with the dimensions shown.



    With the Create Line tool, input the first absolute coordinates in the Cursor Input toolbar. Then enter the successive nodes by moving the mouse in the direction required and typing the distance required.

    Without leaving the Drawing Canvas click the Left Mouse button to accept the placement of each node.



    Create the construction lines using the segments shown above.
  4. Select the single line segment, as shown below, and offset the line in the positive Y direction by 800mm.



    This is going to be the aisle.
  5. Select the line shown below, then click the Add Node button and insert a new node in the middle of the top section of line, as indicated.

    The selected line is going to be used as the profile for the seating in the auditorium. The adding of a node is needed to create the aisle for the seating.

  6. With the line still selected, select the Nodes item from the Select menu (or hit the F3 key, or double click the selected object) to enter Node Mode.

    Now in Node Mode (evident by the red nodes of the selected objects) with the Select tool drag a box around the top two nodes so that they are selected.

  7. Still using the Select tool, move the cursor over the bottom selected node until the Move icon appears next to the cursor.

    Then click the Left Mouse button, to attach the node to the cursor allowing you to edit it's position.

    Move the node to the closest end of the offset line and click the Left Mouse button again to accept the new position (as shown below).

  8. Select just the uppermost node of the same line and move it vertically back in-line with the top line segment.

    This can be done easily by entering the same X value as the previous node, in the Geometry section of the Selection Information panel. Apply the changes by clicking the Apply Changes button.


    This line is now the edge of the first row of seating.
  9. Make a copy of this line at the other end of the two aisle lines.

    Using the Move tool (making sure Apply to Copy is checked in the Options toolbar) snap to one of the central nodes of the line and click the Left Mouse button. Now snap it to the other end of the respective aisle line and click to accept the new position, as shown below.

  10. Select just the uppermost node of the new line and move it vertically back in-line with the top line segment, as was done earlier (this time entering the same Y value).

  11. Select both of the seating lines (front and back) and from the Modify menu choose the Morph Between item.

    This function generates all the interim lines which will be used to create each row of seating.

    Enter 8 in the Morph dialog box and click the OK button.

  12. Finally select all the objects in the scene, choose the Mirror tool and make a mirrored copy of the lines, about the top line segment.

    You may need to adjust the Origin to line up with the top line segment. To do this move the cursor over the Origin, until a small O appears, then left click once to move it.



    The construction lines are now complete.

Creating the Auditorium Zone

We are now going to create the internal envelope of the auditorium. This will involve the construction lines we just created, as well as others, and the use of Cutting Planes.

  1. First select the Zone tool and trace around the outer most lines to create the auditorium zone (make sure snaps are set to Points).

    When you've finished hit the Escape key and rename the zone Auditorium.



    Now view the model in perspective view.

  2. Select the floor element of the new zone. In the Extrusions Vector section of the Selection Information panel, change the Z value to 8000, making sure to apply the changes.

  3. Using the Line tool, create three lines as shown below.

    The first at the mid-height of the wall behind the stage; the second in the middle, at the top of the wall segments over the audience area; and the third at the mid-height of the wall behind the seating.

  4. The height of the first and the third lines now have to be changed to a height of 5000. Select the first line, hit F3 to enter Node Mode, and select all the object's nodes.

    In the Geometry section of the Selection Information panel, change the Z value to 5000 and apply the changes. This shifts the nodes, and thus the whole line, up to 5000mm in the Z axis.


    Now do the same with the third line at the back of the auditorium, but move the line to a height of 6000.

  5. Now using the Plane tool draw two planes; the first around the endpoints of the first and the second line just drawn; and the second around the endpoints of the second and the third line just drawn.

    These are going to be used as cutting planes to trim the top of the auditorium.

  6. Select one of the planes and assign it as a Cutting Plane. Either right-click in the Drawing Canvas to display the pull-right menu and select Cutting Plane - Assign Object, or from the Modify menu.

    It is now necessary to check that the cutting plane's normal is pointing in the right direction. The normal determines which side of the cutting plane, objects are removed from.

    Hit F7 to enter Side view and if the normal is pointing down, hit Ctrl+R to reverse the objects normal (the plane must be selected) so it is pointing upwards as shown below.

    Objects are trimmed on the side of the arrow.

  7. Go back into Perspective view (the F8 key), and select the floor object of the Auditorium zone (if you find it hard to select the correct object, remember to use the Spacebar to toggle between objects that are close by). Now from the Select menu choose the Children menu item.

    This now selects all the child objects of the floor, which we are going to apply the Cutting Plane to. To do this select Trim Selection from the Modify menu, or from the pull-right menu of the Drawing Canvas.

  8. Repeat the last step, this time with the other sloped plane assigned as a Cutting Plane.

  9. Now that the ceiling of the auditorium has been trimmed, delete the two planes used to cut the zone, as well as the three lines used as height guides.

    Try viewing the model in Rough Sketch mode (Display menu). As you can see the zone doesn't have a ceiling any more.

  10. Trace over the top of the walls with two planes, sloping in either direction, so that the zone is an enclosed space, as shown below.



    Make sure that the current zone is set to the Auditorium zone, as the two new ceiling planes must be part of that zone to perform calculations later on.



    The basic internal envelope of the auditorium is now complete.

Modelling the Seating Rows using Morph Between...

In this section we are going to quickly generate stepped rows which will represent seating in the auditorium. To do this we are going to use the Morph Between command to automate a lot of the modelling required. However, to design auditorium seating more accurately it should be raked to ensure site lines to the stage are adequate. For a detailed tutorial on designing raked seating, go to Designing Raked Audience Seating in the Acoustics section of the tutorial list.

  1. Create a new zone called Seating and give it a colour other than white. Also make sure that the new zone is set as the Current Zone, as indicated at the top of the dialog box.

    If not performing thermal analysis on a model, it is possible to assign different types of objects separate zones. Generally speaking however, zones should be used to describe enclosed spaces within a building. For more information on how to effectively use zones, go to Layers and Zones in the Concepts section of the main help file.

    In this instances we are going to create a separate Seating zone to make things easier when modelling the geometry (be able to turn the zones on/off etc.). However, later in the tutorial we will have to move all the seating objects on to the Auditorium zone, otherwise the volume of the space will not be calculated correctly (which is important when performing analysis on a model).

  2. Select the group of morphed lines for the seating and ungroup them, either using the Ungroup item from the Edit menu or hit Shift+Ctrl+U on the keyboard.
  3. In Plan view (F5) select and delete all but the two seating lines at the front and the two at the rear of the auditorium, as shown below.

    If you have difficulty selecting multiple objects by dragging a box with the Select tool, try holding down the Shift key while using the Select tool to add single objects at a time. A plusshould appear next to the cursor when a object can be added to the selection.



    These lines were created in the first part of this tutorial to ensure the correct profile and spacing between rows, but are not required any more.

  4. Change back to Perspective view (F8), and assign the wall element shown below as the Cutting Plane.

    This time we are going to use the Cutting Plane as a tool to extend objects. When using it to extend it is not necessary to check the direction of the Cutting Plane's Normal.

  5. Now select the seating lines (on the same side of the centre line as the Cutting Plane) and choose the Extend Selection item from the Drawing Canvas pull-right menu.

    Note the line that extended beyond the Cutting Plane was trimmed in-line with it, whilst the other line segments were lengthened.


    Do the same to the seating lines on the other side.

  6. Using the Plane tool trace around each of the pairs of lines in the node order shown below.



    The order of the nodes is very important when morphing planar objects. This is because the morphing algorithm uses the corresponding Node Index to work out which node translates to which node, on the two objects.

    If you end up with something looking like the image to the left when morphing, this is because the node order of the two objects doesn't directly correspond. For more detailed information on morphing, go to the Object Morphing tutorial of the Advanced Modelling Techniques section of the tutorial list.
  7. In Perspective view (F8) move the front seating plane to a height of 200mm above 0, and the back seating plane to a height of 1800mm above 0.

    The easiest way to do this, is to set the Nudge value to 200 and use the Z key on the keyboard to shift each object in the Z direction.



    To assist when nudging objects, the Status Bar at the base of the Drawing Canvas indicates the total change in distance since the first nudge (it returns to 0 if another command is selected).

  8. Select both of the seating planes and extrude them by negative 200mm in the Z direction (Extrusion Vector section of the Selection Information panel).

    The vertical elements are going to be the risers between the rows of seating.



    At this stage we can switch off the Construction Lines zone from the Zone Management panel, making it easier to see the important elements in the model.

  9. Now that the seating rows have height, we need to remove all but the front and top elements of the two rows, as the other height segments are not required.

    Select the two side, five back and 1 bottom plane (if the Cap Extrusions option is on) of each row and hit the Delete key on the keyboard to erase the objects.



    Now we can start morphing...
  10. Select two corresponding objects in the front and the back rows, and select the Morph Between item from the Modify menu. When the Morph dialog box appears, enter 7 interim steps and click the OK button.


    Now go through each pair of elements in the two rows and apply a morph with 7 interim steps between each, until all the row elements are complete as shown below. Use the F2 key to repeat the last command.



    The final step is to trim the elements that extend outside the auditorium.
  11. Select either of the small wall elements that runs North/South (shown below) and assign it as the Cutting Plane.



    Then select all the Seating zone elements and apply the Trim Selection tool.

    The easiest way to select all the objects on one zone is by clicking the Right Mouse button on the zone name in the Zone Management panel, and choosing the Select Objects On item.



    Notice that both sides of the seating rows were trimmed. This is because when a Cutting Plane is assigned it becomes an infinite object, that is it extends infinitely along its plane.

Fixing the Auditorium's Volume

To complete the auditorium geometry the floor of the auditorium must be limited to the space above the seating. In other words the floor element of the Auditorium zone must not pass underneath the seating. If the floor was left as it is at the moment, any acoustic analysis done would be extremely inaccurate. This is because the volume of a space is very important when determining Reverberation Time etc. and at the moment the volume includes all the space underneath the seating, which is incorrect.

  1. First, select the top plane of the rear seating row and hit F3 to enter Node Mode.

  2. Now in Plan view (F5), select one of the nodes closest to the rear of the auditorium and shift it with the Select tool (Move icon should appear) until it snaps to the nearest point on the back wall, as shown below.

  3. Repeat the last step until all but the two central nodes are aligned with the rear of the auditorium.

  4. Select the two central nodes, then click the Delete Node button on the Standard toolbar, or hit the Delete key.



    This should remove the two nodes such that the plane follows the edge of the rear walls.

  5. Go back to Perspective view and take a look at the adjustments that were just made.



    Notice that the plane is still flat (and at 1800 high) despite snapping to nodes above and below it. This is because we made the adjustments in Plan view, which maintains the original plane of operation.

    To test the theory, try doing steps 2 and 3 in Perspective view and see what happens.
  6. The next step is to edit the nodes on the floor element so that it follows the edge of the front row of seating.

    First select the floor element and unlink it from the walls (otherwise editing the floor will edit the position of the walls, because the floor is the parent of the walls). To do this, from the Edit menu select Unlink Objects.

    For more information on object linking, go to the Object Relationships page in the Concepts section of the main help file.



    Then follow the instructions from step 2, tracing around the first row of seating then deleting the excess nodes. This can be done in Perspective view if you like, as there are nodes on the same level to snap to.

  7. Next we need to adjust the walls such that they meet at the bottom of either floor or seating depending on the location of the wall segment.

    For the back three walls this means lifting the base nodes to a height of 1800, in-line with the back seating row.



    For the large side walls, this means tracing the profile of the steps by adding additional nodes.

    Select the wall element, and using the Add Node tool insert nodes at the junction of each row of seating. Move the first and last base nodes up until they meet the nearest step, as shown.


    The same needs to be done for the small walls that run North/South.



    Repeat the modifications for the other side of the auditorium.



    When complete the model should look similar to the images below, in both Front and Side views.

  8. The last step is to add two doors at the rear of the auditorium. Select the very back wall and hit the Insert key on the keyboard. Select Door button, and set the dimensions to 2100mm high and 1000mm wide.
    Move the door in the Y direction by 2500 (using the Move tool) then mirror the door about the centre line of the auditorium so that there are two exits.

Modelling the Control Room

The first part of modelling the control room for the auditorium, is to create a whole at the rear of the hall. Geometry is then going to be added around that.

  1. In Side view (F6), click the Add Node tool and click the top of the back wall to start inserting a node.

    In the Cursor Input toolbar specify an X value of 2000, a Y value of -1300 and a Z value of 6000. Click the Left Mouse button in the Drawing Canvas to accept the position of the new node.



    Note that all node insertions use absolute values in the Cursor Input toolbar.
  2. Use Align snaps to align the cursor with the top of the doors and the last node, to insert the next new node.

  3. Insert the third node in line with the top of the doors and with a absolute distance in the Y axis of 1300 (to do this easily make sure the Snaps distance is set to 100 with Grid snaps on).

  4. The final node can be inserted simply using the Align snaps.

  5. Using the Create Zone tool and with Points snaps on, start a new zone at the bottom of the hole in the rear wall, as shown below.

  6. Now in Plan view (F5), move the cursor in the -X direction and type 2000. Then left click to accept the node position.

  7. Move the cursor in the -Y direction, type 2600 and left click to accept the node position.

  8. Move the cursor in the +X direction, type 2000 and left click to accept the node position, or use the Points snap.

  9. Move the cursor in the -Y direction, type 500 and left click to accept the node position.

    This next section is the small balcony that protrudes into the auditorium space.

  10. Move the cursor in the +X direction, type 750 and left click to accept the node position.

  11. Move the cursor in the +Y direction, type 3600 and left click to accept the node position.

  12. Move the cursor in the -X direction, type 750 and left click to accept the node position.



    Once that's done and it looks similar to the image above, hit the Escape key twice to finish the zone and exit the Rename Zone dialog box.
  13. Select only the floor element of the zone you just created.

    In the Extrusion Vector section of the Selection Info. panel give the zone a new height of 2090 in the Z axis. Hit the Apply Changes button so the changes will take effect.

  14. Select all the objects on the new zone, and in the Edit menu choose the Unlink Objects item.

    Now that the zone is unlinked you are free to edit any element in the zone without it effecting any other element in the zone.



    Select the five wall segments that make up the balcony section of the new zone and hit the F3 key to enter Node Mode.
  15. In Side view, drag a box around the top of the wall elements to select all of the top nodes.

  16. Hold down the Shift key + Z and move the nodes down 1300 so that they make a railing around the balcony.

  17. Hit the F4 key to isolate the current zone, then click the Zoom Fit Grid tool. Once you've zoomed in to the control room, select the panels shown below and delete them.

    These elements need to be removed as they overlap part of the rear wall and are unnecessary.

  18. Select the ceiling element and hit the F3 key to enter Node Mode. Now select the four front nodes which overhang the balcony and delete them.



    The control room is now complete and should look similar to the image below.

  19. Hit the F4 key again to toggle back to displaying all the zones, then click the Zoom Fit Grid tool to zoom back out.

    The final step is to move all the objects (except the construction lines) onto the Auditorium zone.



    To do this select the objects except the construction lines (you might like to try locking the Construction Lines zone to avoid selecting them), then in the Selection Info. panel click the Zone input box and select the right arrow icon that appears.

    This should display a small list of options. From the list choose the Select Zone item, then in the Select Zone dialog box choose the Auditorium zone then click the OK button.

    All the selected objects now belong to the Auditorium zone.
  20. It is necessary to change all the objects to the Auditorium zone so that the space is completely enclosed, allowing an accurate calculation of the volume of the auditorium.

    Just as a test, from the Calculate menu choose the Zone Volumes item. ECOTECT goes off and calculates the volume of the zone, spraying rays within the space.

    As a check the final volume should be just over 1000m3, as long as your measurements are consistent with those used throughout the tutorial. This is displayed in the Geometric Data section of the Selection Info. panel.