ADVANCED MODELLING - Importing CAD Geometry

Introduction

Although ECOTECT has it's own modelling interface, it is possible to import geometry from other CAD packages via DXF or 3DS files. It is rare (virtually impossible really) to import geometry into ECOTECT and expect the program to understand all of the geometry and not require additional work/editing in ECOTECT. Unlike many CAD programs, ECOTECT needs to understand the geometry as a building. This is the only way that analysis can be correctly undertaken. Therefore when importing geometry it is important to thoroughly check it, especially material assignments.

The best way to approach the import of geometry is to firstly be clear about what you want to do with it in ECOTECT, and secondly to work out what is necessary to import to effectively achieve your aim. As an example, it is a waste of effort modelling an entire building's geometry in AutoCAD, then expecting it to import and perform thermal analysis correctly in ECOTECT. Thermal models need only be very simple representations of the building's spatial zones. For more information on this, refer to the Thermal Modelling page in the Analysis section of the ECOTECT help file.

Import for Thermal

Because thermal analysis is very specific in it's geometric requirements (with regard to zoning and primary/alternate materials), it is recommended that 3D geometry be (in the most part) created in ECOTECT, as opposed to importing a full 3D CAD model from another program. However, what is very useful is using existing 2D drawings to trace over in ECOTECT. Refer to the 2D import section below.

Import for Solar & Lighting

Solar and lighting analysis is more accurately undertaken with quite detailed 3D geometry. ECOTECT needs to know less about the building than for a thermal analysis, therefore it is reasonable to import full 3D geometry. However it is important to remember to specify the materials of all surfaces correctly in order for reflected and transparent objects to be accurately considered. Refer to the 3D import section below.

Import for Acoustics

Similar to thermal analysis, acoustic analysis requires accurate zoning and material specification. Therefore, like thermals, it is recommended that 2D drawings be imported to trace from in ECOTECT. Refer to the 2D import section below.

General Points to Remember

2D Import - DXF Files

ECOTECT will not read blocked or referenced objects. Therefore it is important that you explode any block or group objects before exporting as a DXF.

ECOTECT will also not understand very well change in UCS made to create objects. Objects created with an altered UCS may import out of alignment and orientation.

If exporting from AutoCAD, type use dxfout entered at the command line and in the SaveAs DXF dialog box, choose the Options button, then the DXF Options tab and make sure the Select Objects checkbox is ticked. It is important to only export the drawing objects, otherwise the DXF file will include all the line-style tables and redundant layers etc.

  1. To import a DXF file, choose the Import... item from the File menu.

    Open the 2D Drawing.dxf file in the Tutorial Files directory in the ECOTECT installation directory. You will need to make sure the Files of Type list has AutoCad DXF Files chosen.

    The following dialog box will appear allowing you to specify import settings.

  2. When importing a 2D drawing to trace over, it is recommended that you tick the CREATE ALL OBJECTS AS CONSTRUCTION LINES option.

    This will ensure that closed DXF polylines are not interpreted as additional floor planes separating the model from the ground, thus affecting analysis results. The option makes all imported DXF objects of type LINE and assigns them the default line material.
  3. Make sure the options are similar to the ones shown in the dialog box above, then click the OK button to import the file.



    For more information on the different options in this dialog box, take a look at the DXF Import page in the ECOTECT help file.
  4. To start tracing from the 2D drawings, it is useful to lock the zones with the imported lines on, so as not to alter the imported geometry.

3D Import - 3DS Files

With very large and complex 3DS files (> 1MB) it is recommended that the geometry be exported as several separate files. ECOTECT will be able to handle very complex geometry once loaded but, due to the way ECOTECT handles 3DS files, it may actually take significantly longer to load one large file than several smaller ones. This is mainly due to the temporary storage and memory management required as the 3DS file is being interpreted in ECOTECT.

  1. To import a 3DS file, choose the Import item from the File menu.

    Open the 3D Model.3ds file in the Tutorial Files directory in the ECOTECT installation directory. You will need to make sure the Files of Type list has 3D Studio Files chosen.
  2. There are no options for 3DS file import, therefore the objects should be displayed in the drawing canvas immediately after loading.

  3. Notice that the geometry is triangulated.

    This is characteristic of a 3DS file, and occurs when the geometry is exported by the CAD program, not by ECOTECT when it imports the geometry.
  4. If you don't want the geometry to be triangulated, select the objects just loaded and choose the Merge Coincident Triangles item from the Modify menu.



    This function may not work with all triangles and can occasionally get a bit confused with some geometry, like the base plane in the example model shown above. In these instances it may be appropriate to manually correct some of the resulting geometry.
  5. You may also notice that the imported geometry is also grouped together.

    This is because most geometry from a 3DS file is quite complex, and it was thought that grouping the geometry on import would make it easier to handle.

    To ungroup the objects, hit Shift+Ctrl+U or choose the Ungroup item from the Edit menu.