ADVANCED MODELLING - Background Bitmap

Loading a Background Bitmap

  1. Start with a new model file.

    From the File menu select the New item, or click the New File button from the Main toolbar.

  2. From the View menu select the Background Bitmap item, or from the Model Settings dialog box click the Bitmap tab.

    The Bitmap tab in the Model Settings dialog box will be displayed. From here it is possible to load an image file and modify its properties.
  3. Click the Load Bitmap... button.

    A standard Windows Load File dialog box appears. Navigate to the Tutorials directory within the ECOTECT install directory. Double click the bitmap file labeled House Plan.bmp.
  4. ECOTECT returns to the Bitmap settings.

    Click OK to exit out of the dialog box and return to the Drawing Canvas.
  5. If the model view is set to perspective your canvas may look something similar to the one displayed below.



    It is not possible to view an image in perspective view, therefore in place of the image a bounding box with two diagonal lines through is displayed instead.

    To view the image go to Plan view, either from the View menu or hit F5 on the keyboard.
  6. Before going on to the next section you may like to try some of the different display modes in the Bitmap tab of the Model Settings dialog box.

    Inverted is usually the best option for a black Drawing Canvas.

Scaling the Bitmap

To ensure the correct size for the imported bitmap, a section of the image needs to be measured. This needs to be a part for which a real dimension is known. In this instance we are going to use the northern wall of the garage, which (as shown below) needs to be a distance of 6000mm.

  1. Using the Measure tool, measure the northern wall of garage.

    To get an accurate measurement, zoom in on the garage using the Zoom Window button.

    The measurement information is displayed in the Selection Info. panel.
  2. Return to the Bitmap tab in the Model Settings dialog box.

    Enter the distance measured in the previous step in the Measured Distance input box, then enter 6000 in the Real Distance input box.

    Make sure you hit the Apply button before continuing.
  3. Return to the Drawing Canvas and press Ctrl+F or click the Fit Grid button.

    This will resize and zoom the grid to the new image size.
  4. To check the new image size, re-measure the northern wall of the garage.

    The distance should now be 6000.

Tracing the Bitmap

Most scanned images (in this case a plan) will show some wall thickness around the perimeter and between rooms. This leads to the question 'which side of the wall do I trace?'.

In most cases you will actually trace the centre as thermal calculations require single-plane walls around and between zones. The centre gives the closest approximation between the surface area exposed to outside conditions and the internal volume, as well as ensuring that the walls of adjacent zones properly meet.

For more complex lighting and shadow models, where accuracy of geometry is the overriding requirement, you will probably want to trace both sides of the walls, or simply trace the inside and extrude the windows outwards to represent the wall depth.

If modelling for thermal calculations, it is also important to decide how to divide the building into appropriate zones.


The image to the right shows an example of the thermal zoning that could be applied to this particular house plan.

There are a number rules for zoning that apply to any type of building when performing thermal analysis, these are:

  1. A thermal zone represents an enclosed space within which the air is free to flow around and whose thermal conditions are relatively consistent. In most cases, any room that can be closed off with a door would be a separate zone.
  2. Sometimes temperatures in different parts of large spaces can vary. In these cases, the space can be divided into a number of smaller zones with adjoining elements defined as voids. This way heat is free to flow between the zones, but their thermal characteristics can be analysed individually.
  3. Also, adjacent utility spaces such as store rooms, toilets and corridors can often be grouped together into the one zone. This is because the exact temperature of each utility space is seldom of interest, but their action as a thermal buffer between other zones may be important.
 

If using ECOTECT only for shading and lighting calculations, the division of zones is not as important and they can be used as layers to separate objects and functions. However, thermal and acoustic calculations require very specific zoning based on the above rules.

  1. Having decided the requirements for the model (ie. thermal / lighting / shadows / acoustics) it is possible to start tracing the image.
  2. Using the Zone tool zoom in to the first zone for the building and start drawing.

    It is recommended that the default zone extrusion height is set appropriately first (Modelling tab of the User Preferences dialog box) and that grid snaps be used and set to 100mm. Using a grid snap of 100 will ensure that dimensions are rounded values.

    For more detailed instructions on modelling in ECOTECT try the Simple House tutorial.